A
B
C
Ç
D
E
F
G
Ğ
H
I
İ
J
K
L
M
N
O
P
R
S
Ş
T
U
Ü
V
Y
Z
Q
W
X
+ Ekle
Cisco HSRP Nedir?

Cisco HSRP Nedir?

H S R P  Nedir?

HOT STANDBY ROUTER PROTOCOL (HSRP) 

Paketlerin iletilmesi ;Osi 3. katmanda çalışan cihazlar aynı networkdeki hedef makine ile doğrudan iletişime geçebilmek için arp adresini bilmesi gerekir bunun için de Arp sorgulaması yaparak   karşı tarafın MAC adresini öğrenmiş olur.Arp sorgulaması broadcast olarak yapılır o zaman aklımıza su sekil bir soru gelebilir; broadcast paketler router uzerinden geçemiyor ise hedef ip nin Mac adresini nasıl bileceğiz.Networkumuzde gateway olarak ayarladığımız router veya pc ler kendilerini hedef ip den sorumlu (proxy ) olarak gosterir vede bu arp mesajlarına kendi mac adresi ile cevap verir.Bu nedenle gateway olarak atadığımız cihazın devamlı aktif olması  önemlidir. Gateway adresini  bilmiyorsak veya bu cihazdan cevab alamıyorsak, veri  iletişiminde sorun olacaktır .Bu sorunun çözümü için bir çok protocol (multiple routing cihazlar) gateway adresini paylaşır.Yani birden fazla cihaz aynı ip adresini paylaşırlar.Bu protokollerden  bazıları ;

1)HSRP  (Hot standby router protocol)

2)VRRP (Virtual Router Redundancy Protocol)

3)GLBP ( Gateway Load Balancing protocol)

Bizim burada üzerinde duracağımız protocol HSRP dur.

HSRP: Cisco ya has bir protocoldür bir kaç router a izin verir ve sadece bir gateway var gibi gözükür.RFC 2281 olarak tanımlanır. Gateway adresi HSRP ortak grublarına atanır. Bir router primary olarak seçilir,diğeri active HSRP olarak bir diğeride standby HSRP olarak seçilir. Geriye kalan routerlarda HSRP durumlarını dinler ve düzenli aralıklarla router HSRP hello paketlerini değiştirir.

UDP port 1985 i kullanır

Hsrp grouplarına bir grub numarası verilir bu numara 0 ile 255 arasında olacak şekilde seçilir.Aynı zamanda Vlan üzerinde de  konfigure edebiliriz ama grub numaralarıyla vlan numaraları aynı olması koşuluyla. Şimdi bu işin nasıl işlediğini anlamak için biraz konuyu açacağız.

HSRP ROUTER ELECTION (HSRP Router Seçimi)

HSRP seçimi; belirlediğimiz hsrp grublarının üzerindeki  priority değrinine bağlıdır.Bu değer default olarak 100 dür ,en yüksek değeride 255 dir( 255 ile belirlenen router aktiv router dır). Diyelim ki grup daki bütün routerlar aynı priority e sahip o zaman ne olur. Adamlar her şeyi düşündüğü gibi buna düşünmüşler o zaman rouer en yüksek IP e sahip HSRP interface olarak belirmiş interface in IP sini alır. Priority değerlerini biz kendimiz manuall olarak değiştirebilir bunun için router üzerinde şu komutu girmemiz yeterli olacaktır.

Switch(config-if)# standby groub priority priority

HSRP yi aktiv ettiğimiz zaman,router aktif olmadan önce,grubdaki diğer routerları dinler ve hangi duruma kendini uyduracağını bakar bu durumlar;HSRP durumu aktiv değilse

1)Init

2)Listen

3)Speak

4)Standby

5)Finally

6)Active

Stanby router Active router dan  3sn de birHello mesajları alır,eğer hello mesajlarının hold-timer zamanlaması uymuyorsa aktif router düşer ve standby router active router olur,diğer routerlar dinleme durumunda kalırlar. Aktif rol oynayan stand by routerdan sonra en yüksek priority değerine sahip router standby konumuna geçer. Her şeyi değiştirebildiğimiz gibi bu hold-timer değerinide değiştirebiliriz nasıl mı ? demeden hemen komutumuzu yazalım,

Switch(config-if)# standby group timers hello holdtime

En az 3 sn olarak belirlenmeli ve bütün router üzerinde değiştirilmeli

Routerlar tekrardan başlatıldığında önceki router bir daha aktif olamaz standby durumunda kalır. Önceki aktif router un tekrardan aktif rol oynayabilmesi için şu komutu mutlaka kullanmalıyız.

Switch(config-if)# standby group preempt (delay seconds)

Ayrıca HSRP cleartext  autantication kullanır yani başka grupların dahil olmasından korur.Aşağıdaki komut ile aktif edilir

Switch(config-if)# standby group autantication string

CONCEDING THE ELECTIN (Seçilme için Fırsat Verme);

HSRP grup taki routerları incelyecek olursak, bir çok client paket iletmek isteyecek ve bunu aktif olan çeşitli hatlardan yapacaklar bunlardan biri devre dışı kaldığında yine devam ederler, bu linklerin hepsi düştüğünde router yine aktif  kalır ama kısa bir zaman içinde bu kopan linkler kaldırılır veya işlem yapamaz hale getirilir clientler buradan iletim yapamazlar.Işte HSRP burada devreye girmekte,HSRP de var olan bir mekanizma bunu tespit eder seçimi etkiler ve diğer routerlara aktif olmaları için bir fırsat verir ve HSRP interface düşene kadar router priority sini düşürür. Eğer birden fazla router var ise ortamdaki interfacelerden en az bir tane kalana kadar priority düşürülür bu da şağıdaki komutla yapılır

Switch(config-if)# standby group track type mod/num decrementvalue

Fakat hiç unutmamamız gereken bir komut var eğer biz bu komutu unutursak seçilen router aktif rol oynayamayacaktır bu komut az önce yukarıda yazmış olduğumuz komuttu yani preempt

HSRP GATEWAY ADDRESSING( HSRP de gateway adresi verme):

Her iki routerda da HSRP yi aktif hale getirdik.Eğer aktif router bağlantısı kopacak veya hattan düşecek olursa,standby router görevi devralacak ve trafik bu hattan akacak.

RouterA

version 11.2

no service udp−small−servers

no service tcp−small−servers

!

hostname RouterA

!

!

interface Ethernet0ip address 192.1.1.2 255.255.255.0

no ip redirects

standby priority 200

standby preempt

standby ip 192.1.1.10

!

interface Serial0

no ip address

shutdown



no fair−queue

!

no ip classless

!

line con 0

line 1 16

line aux 0

line vty 0 4

!

End

RouterB

Current configuration:

!

version 11.1

service udp−small−servers

service tcp−small−servers

!

hostname RouterB

!

547

!

interface Ethernet0

ip address 192.1.1.3 255.255.255.0

no ip redirects

standby priority 150

standby preempt

standby ip 192.1.1.10

!

interface Serial0

no ip address

shutdown

!

no ip classless

!

line con 0

line aux 0

line vty 0 4

login

!

en


  • diline pelesenk olmak ne demek
  • dillere pelesenk olmuş ne demek
  • pelesenk
  • pelesenk ne demek
  • Pelesenk Ne Demek – Pelesenk Sözlük Anlamı
  • pelesenk olmak ne demek
  • pelesenk olmak ne demektir
  • pelesenk olmuş ne demek
  • Yüksek Yüksek Tepelere sözleri
  •   Ad Soyad
      Yorum